Flagi,logika ustawiania.

Problemy przy montażu oprzewodowania i urządzeń KNX / EIB.
Gadgetman1
Posty: 123
Rejestracja: 19 sty 2014, o 15:10

Flagi,logika ustawiania.

Post autor: Gadgetman1 » 1 maja 2014, o 16:16

Jak wiecie zapewne flagi poprawnie ustawione to 100% poprawnie działająca magistrala.Może istnieje gdzieś jakis wzór ustawiania flag ,ja go nie znalazłem więc bazuję na metodzie prób i błędów.Stoczyłem wygrany bój ściemniacze vs.Prion.Każda lampa którą bym nie zapalił czy to z kilku przycisków czy też menu paneli załącza się poprawnie bez konieczności np.dwukrotnego przycisku.Status lampy % pojawia się poprawnie z kilku podmenu jak i z przycisków (podświetlenie led zmienia barwę w zależności od % ustawienia ściemniaczy) .Przedemną kolejna bitwa sterowniki rolet vs.Prion. Niby że po części działa wszystko poprawnie.Aktywując w menu daną funkcję rolety mam status ikony zamknięta otwarta.Grupy rolet też działaja poprawnie.Problem pojawia sie gdy aktywowany np.jest timer tygodniowy czy też np jakaś scena.Oczywiście rolety działaja poprawnie tylko nie zapisuje sie status czy zostały otwarte czy też zamknięte czyli wchodząc do menu paneli powinienem widzieć status ikony otwarta ,zamknięta tak jak w przypadku pojedynczej rolety czy też grup rolet.Niby że w adresach grupowych danych funkcji są te same przypisanie flagi niestety nie działa to.Oczywiście nie jest to bardzo istotny element całej magistrali ale wiem że nie do końca jest to poprawnie a naprawdę szkoda mi juz urządzeń i czasu na wpatrywanie sie w pasek postępu ładowania aplikacji.Może w końcu ktoś się znajdzie tu na forum dysponując wiedzą (i chęcia sie z nią podzielenia!!) i podpowie gdzie jest problem.

ODPOWIEDZ